Configuració de switch Cisco

En aquest manual es poden trobar algunes comandes bàsiques de configuració de switch Cisco. Aquest manual estarà en permanent edició i actualització així que és possible que moltes de les opcions de configuració no apareguin actualment.

VLANS

Agregar VLAN

Switch$ enable
Switch# configure terminal
Switch(config)# vlan vlanId
Switch(config)# name nomVlan

Veure VLANs i ports assignats

Switch# show vlan brief //mostra l'arxiu vlan.dat)
Switch# show vlan id vlanID //mostra informació sobre la VLAN demanada
Switch# show vlan name vlanNombre //mostra informació sobre la VLAN demanada

Mostra port

Switch# sh interfaces switchport //mostra informació sobre tots els ports
Switch# sh interfaces fa1/1 switchport //mostra informació d'una fa en concret

Assignació de ports

Switch(config-if)# switchport mode access //defineix el mode d'associació com a estàtic
Switch(config-if)# switchport access vlan 111 //assignem port a vlan

Elimina assignació de ports

Switch(config-if)# no switchport access vlan //Eliminem assignació de vlan

Eliminar una VLAN

Switch(config)# no vlan 33

Ports troncals

Switch(config-if)# switchport mode trunk

Elimianció de ports troncals

Switch(config-if)# no switchport mode trunk allowed vlan

VTP

Creació del domini VTP (Key sensitive!!)

Switch(config)# vtp domain <nom>

Mode VTP

Switch(config)# vtp mode client/transparent/server

Veure detalls d’VTP

Switch# show vtp status

Comunicació entre VLANs

Comunicació amb switch de Capa 3 (Multicapa)

Configuració switch veí: L’enllaç amb el switch veí s’ha de configurar com a troncal.

Habilitar l’enrutament

Switch(config)# ip routing

Creació de les VLAN i assignació de l’adreça corresponent a cada VLAN

Switch(config)# interface vlan X //Accedir a configuració de VLAN
Switch(config-if)# ip address X.X.X.X M.M.M.M //Assignació IP a VLAN
Switch(config-if)# no shutdown //Interfície posada a up

Configurar interfície que connecta amb el router (si n’hi ha)

Switch(config-if)# no switchport //permet entrar a configuració de Capa 3
Switch(config-if)# ip address X.X.X.X M.M.M.M
Switch(config-if)# no shutdown

Configurar la ruta per defecte per a totes les configuracions externes

Switch(config-if)# ip route 0.0.0.0 0.0.0.0 IP_If_Router

Comunicació amb router

Configuració switch veí: L’enllaç al switch veí s’ha de configurar com a troncal.

Creació de subinterfícies al router

Router(config)# interface fastEthernet 0/0
Router(config-if)# no shutdown
Router(config)# interface fastEthernet 0/0.10

Configurar encapsulació 802.1Q i VLAN

Router(config-subif)# encapsulation dot1q vlan_id

Assignació d’adreça IP a les subinterfícies

Router(config-subif)# ip address X.X.X.X M.M.M.M
Router(config-subif)# exit
Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: